Completed Support Virtualizor Plugin

Feature Request has been implemented

Waqass

New Member
Going to try it now. Blesta already had this. Glad CE has extended support for virtualizor as solusvm is very limited in terms of features.
 

Waqass

New Member
Finally managed to get it run. The plugin has created the user and vps under virtualizor as expected. However when I try to view the VPS package details under CE the screen goes inactive and response never comes. I have checked with the server team and both incoming and outgoing ports of virtualizor are open so port blockage might not be the issue specially when its creating vps normally. What else this can be. 1584562287851.png
 
Last edited:

Waqass

New Member
I have created the ticket and even enabled logging at level 4. Here is the output of that when I click the virtualizor product
Code:
(3) 03/19/20 20:26:01 : (home/hostmayo/public_html/members/library/CE/Lib.php:259) - ** VIEW REQUEST ** (direct access) Module: admin - executeservice
(4) 03/19/20 20:26:02 : (home/hostmayo/public_html/members/library/Zend/Controller/Action.php:516) - ** Running service: order
(3) 03/19/20 20:26:16 27.255.48.169:2022 (home/hostmayo/public_html/members/library/CE/Lib.php:259) - ** REQUEST ** GET /members/admin/index.php?fuse=clients&controller=userprofile&view=profileproduct&groupinfo&id=2876&frmClientID=266
(3) 03/19/20 20:26:18 27.255.48.169:2023 (home/hostmayo/public_html/members/library/CE/Lib.php:259) - ** REQUEST ** GET /members/admin/index.php?fuse=admin&view=activecustomer&nolog=1
(3) 03/19/20 20:26:19 27.255.48.169:2034 (home/hostmayo/public_html/members/library/CE/Lib.php:259) - ** REQUEST ** GET /members/admin/index.php?fuse=clients&action=admingetclientproductfields&settingtype=groupinfo&packageId=2876
(4) 03/19/20 20:26:19 27.255.48.169:2034 (home/hostmayo/public_html/members/modules/clients/models/UserPackageGateway.php:1783) - Calling Server action CheckUserName on package 2876
(4) 03/19/20 20:26:19 27.255.48.169:2034 (home/hostmayo/public_html/members/modules/admin/models/server.php:73) - Called plugin function virtualizor -> getVariables
(3) 03/19/20 20:26:20 27.255.48.169:2033 (home/hostmayo/public_html/members/library/CE/Lib.php:259) - ** REQUEST ** GET /members/admin/index.php?fuse=clients&action=getavailablepluginactions&id=2876
(4) 03/19/20 20:26:20 27.255.48.169:2033 (home/hostmayo/public_html/members/modules/admin/models/server.php:73) - Called plugin function virtualizor -> getVariables
(3) 03/19/20 20:26:20 27.255.48.169:2039 (home/hostmayo/public_html/members/library/CE/Lib.php:259) - ** REQUEST ** GET /members/admin/index.php?fuse=admin&view=activecustomer&nolog=1
(3) 03/19/20 20:26:21 27.255.48.169:2031 (home/hostmayo/public_html/members/library/CE/Lib.php:259) - ** REQUEST ** GET /members/admin/index.php?fuse=clients&action=getprofilecounts&controller=user&id=266
 

Waqass

New Member
Hey Matt! thanks for the patch. The product is now loading fine though still unable to create the VPS. Throwing error "
Please choose a OS for the VPS". I think the VM Operating System Custom Field is not being passed on. I have doubled check and everything is properly configured at my end.
 

Waqass

New Member
One more thing, the VPS is created when creating openvz based VPS though with centos not matter what os you select. And it plainly doesn't creates VPS when trying to build it for KVM based throwing error "Please choose a OS for the VPS" .
 
Last edited:

CE-Matt

Administrator
Staff member
Virtualizor requires the template id, not name when passing it. The OS custom fields should be something like "Cent OS 7.x(1), CentOS 8.x(2)" etc.
 
Top